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Introduction
Oracle Migration Workbench (Migration Workbench), release 9.2.0 enables 
you to migrate the following databases to an Oracle9i or Oracle8i database:

■ Informix Dynamic Server 7.3

■ Microsoft Access 2.0, Microsoft Access 95, Microsoft Access 97, and 
Microsoft Access 2000

■ Microsoft SQL Server 6.5

■ Microsoft SQL Server 7.0

■ Microsoft SQL Server 2000

■ MySQL 3.22 and MySQL 3.23

■ Sybase Adaptive Server 11

■ Sybase Adaptive Server 12

■ IBM DB2/AS400 V4R5

Purpose of this Document
This document outlines how to install the Migration Workbench. It also 
provides tips on using the Migration Workbench. For more information on 
the Migration Workbench, see the following documentation:

■ Oracle Migration Workbench Reference Guide for Informix Dynamic 
Server 7.3 Migrations

■ Oracle Migration Workbench Reference Guide for Microsoft Access 2.0, 
95, 97, 2000 Migrations

■ Oracle Migration Workbench Reference Guide for Microsoft SQL Server 
6.5, 7.0, 2000, and Sybase Adaptive Server 11, 12 Migrations

■ Oracle Migration Workbench Reference Guide for MySQL 3.22, 3.23 
Migrations

■ Oracle Migration Workbench Reference Guide for IBM DB2/400 V4R5 
Migrations

■ Oracle Migration Workbench Frequently Asked Questions

■ Oracle Migration Workbench Online Help
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New Features in this Release
The following new plug-ins and features are supported by of release 9.2.0 of 
the Migration Workbench:

■ Plug-in for DB2 V4R5 on the AS400

■ T/SQL Parser Intelligence Improvements

Plug-in for DB2 V4R5 on the AS400
The IBM/AS400 V4R5 plug-in was developed using 9.2.0 dependencies, 
and upgraded to work against the 9.2.0 Migration Workbench core.

T/SQL Parser Intelligence Improvements
The T/SQL parser contains parser intelligence capable of working out the 
inter-dependencies of stored procedures. The first phase of the Parser 
Intelligence feature was completed in version 2.0.2 of the Oracle Migration 
Workbench. However, with some of the more complex Sybase Adaptive 
Server databases, schema objects are stored in tempdb and referenced by 
stored procedures in other databases. These objects need to be migrated as 
part of a database migration. T/SQL Parser Intelligence has been improved 
in release 9.2.0 to handle temp tables generated by references to other temp 
tables.

Setting Up the Migration Workbench
Before you install the Migration Workbench, review the Hardware 
Requirements and Software Requirements topics.

Hardware Requirements
The Migration Workbench has the following minimum and recommended 
hardware requirements:

■ Personal computer based on an Intel 80486 processor or higher. A 
minimum of Pentium 233Mhz processor is recommended.

■ 128MB RAM (256MB recommended).

■ 286MB hard disk space for the installation of the Migration Workbench 
and its dependencies. 

■ VGA video (SVGA is recommended).

■ Microsoft Windows 98/2000 or Microsoft Windows NT compatible 
network adapter.
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Software Requirements
The Migration Workbench has minimum and recommended software 
requirements. This sections contains the following:

■ General Requirements

■ Informix Dynamic Server 7.3 Requirements

■ Microsoft Access 2.0, 95, 97 Requirements

■ Microsoft Access 2000 Requirements

■ Microsoft SQL Server 6.5, Microsoft SQL Server 7.0, and Microsoft SQL 
Server 2000 Requirements

■ MySQL 3.22, 3.23 Requirements

■ Sybase Adaptive Server 11 and Sybase Adaptive Server 12 
Requirements

■ IBM DB2/AS400 V4R5 Requirements

General Requirements In order to migrate any plug-in, it is recommended 
that you have the following:

■ Microsoft Windows NT 4.0 (Service Pack 6.0a) or Microsoft Windows 
98/2000.

■ At least 30MB of space available in the tablespace where you create the 
Migration Workbench repository. You should create a separate default 
tablespace for the user of the Migration Workbench repository.

Informix Dynamic Server 7.3 Requirements In order to migrate from Informix 
Dynamic Server 7.3 to Oracle, you must have the Informix JDBC Driver 1.4 
installed on the same system as the Migration Workbench.

The Informix JDBC Driver 1.4 is available from the Informix Dynamic 
Server 7.3 CD. To install the Informix JDBC Driver 1.4, follow the 
instructions in the install.txt file. You can locate the install.txt file in the 
JDBC directory. 

Note: After you have installed the Informix JDBC Driver 1.4, copy 
the ifxjdbc.jar file of the driver to the 
%ORACLE_HOME%\Omwb\drivers directory.
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Informix Dynamic Server Logging Script Issue In order to migrate to a 
destination Oracle database using the Migration Workbench, logging must 
be turned on in the Informix Dynamic Server database. The Migration 
wizard can then use the following Informix Dynamic Server syntax:

database:owner.object

The Informix sysmaster database must exist under the Informix Dynamic 
Server that controls the databases you want to migrate.

Microsoft Access 2.0, 95, 97 Requirements In order to migrate from Microsoft 
Access 2.0, Microsoft Access 95, and Microsoft Access 97 to Oracle, you 
must have the following installed on the same system as the Migration 
Workbench:

■ An ODBC driver release 4.00.4202.00 or greater. You can obtain this 
by downloading the latest version of the Microsoft Data Access 
Components (MDAC) from the Microsoft Web site at:

http://www.microsoft.com

■ Microsoft Data Access Objects (DAO) Release 3.5. You can obtain 
this by downloading Microsoft Access 97. 

■ Microsoft Access 97. 

■ You must install the Oracle ODBC driver to allow Microsoft Access 
forms and reports to work with the migrated data. Once you have 
installed the Oracle ODBC driver, you should set the Oracle ODBC 
Data Source. For more information, see Setting the Oracle ODBC 
Data Source in the online help.

Microsoft Access 2000 Requirements In order to migrate from Microsoft 
Access 2000 to Oracle, you must have the following installed on the same 
system as the Migration Workbench:

■ An ODBC driver release 4.00.4403.02 or greater. You can obtain this 
by downloading the latest version of the Microsoft Data Access 
Components (MDAC) from the Microsoft Web site at:

http://www.microsoft.com 

■ Microsoft Data Access Objects (DAO) Release 3.6. You can obtain 
this by downloading Microsoft Access 2000. 

Note: The Oracle ODBC driver is automatically installed 
by default when you install the Migration Workbench.

http://www.microsoft.com
http://www.microsoft.com
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■ Microsoft Access 2000.

■ You must install the Oracle ODBC driver to allow Microsoft Access 
forms and reports to work with the migrated data. Once you have 
installed the Oracle ODBC driver, you should set the Oracle ODBC 
Data Source. For more information, see Setting the Oracle ODBC 
Data Source in the online help.

 

Microsoft SQL Server 6.5, Microsoft SQL Server 7.0, and Microsoft SQL Server 2000 
Requirements In order to migrate from Microsoft SQL Server 6.5, Microsoft 
SQL Server 7.0, or Microsoft SQL Server 2000 to Oracle, you must have the 
Microsoft SQL Server ODBC driver release 3.70.06.23 or higher installed on 
the same system as the Migration Workbench. The ODBC driver is shipped 
with the Microsoft SQL Server client software.

MySQL 3.22, 3.23 Requirements In order to migrate from MySQL to Oracle, 
you must install the MM MySQL JDBC driver Release 1.2a on the same 
system as the Migration Workbench. You can obtain this by downloading 
the MM MySQL JDBC driver from the WorldServer Web site at:

http://www.worldserver.com/mm.mysql

Copy and unzip the mm.mysql.jdbc-1.2a.zip file to the 
%ORACLE_HOME%\Omwb\drivers directory. This automatically creates a 
new directory called mm.mysql.jdbc-1.2a within the drivers directory.

Sybase Adaptive Server 11 and Sybase Adaptive Server 12 Requirements In order 
to migrate from Sybase Adaptive Server to Oracle, you must have the 
Sybase Adaptive Server ODBC driver Release 3.11.00.01 or higher installed 
on the same system as the Migration Workbench. The Sybase Adaptive 
Server ODBC driver is shipped with the Sybase Adaptive Server 11 and 
Sybase Adaptive Server 12 client software.

IBM DB2/AS400 V4R5 Requirements In order to migrate from IBM DB2/AS400 
V4R5 to Oracle, you must have the following installed on the same system 
as the Migration Workbench:

■ The jt400.jar JDBC driver from the IBM Java Toolbox for AS/400 V4R5. 
You can obtain this from the JTOpen website at:

http://oss.software.ibm.com/developerworks/opensource
/jt400

Note: The Oracle ODBC driver is automatically installed 
by default when you install the Migration Workbench.

http://www.worldserver.com/mm.mysql
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To download the jt400.jar file:

1. Click the Toolbox Downloads link in the overview section.

2. In the following page click download JTOpen.

3. Enter your user ID and password.

4. Download the jtopen_x_xx.zip file.

5. Extract the jt400.jar file to %ORACLE_HOME%/omwb/drivers 
directory.

Installing the Migration Workbench

To install the Migration Workbench:

1. Start Windows NT or Windows 98/2000.

2. Log on to the system as a member of the Administrators Group.

3. Insert the Oracle9i R2 CD-ROM into the CD-ROM drive.

4. The Oracle Universal Installer launches automatically.

5. Click Next.

6. In the Name field of the Destination section, enter the name of the 
Oracle home where you would like to install the Migration Workbench. 
For more information about %ORACLE_HOME%, see the Installing into an 
Oracle Home Directory topic.

7. In the Path field in the Destination section, enter the path of the Oracle 
home directory. Click Next.

8. From the Oracle Universal Installer Available Product dialog box, select 
the Oracle9i Client 9.2.0.1.0 option. Click Next.

9. Select the Custom option and click Next.

Note: The native JDBC driver shipped with the AS/400 
Developer Kit for Java is not appropriate for use with the 
Migration Workbench, as it only runs on the AS/400 JVM. 
The JDBC driver from the IBM Java Toolbox for AS/400 
V4R5 is used as it runs on any JVM.

Note: The name of the Oracle home directory must be 1 to 16 
characters long. It can only include alphanumeric characters and 
underscores.
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10. From the Oracle Universal Installer Available Product Components 
dialog box, select the Oracle Migration Workbench 9.2.0.1.0 
component.

11. Click Next.

12. Review the Summary window for accuracy, then click Install. The 
Install window appears showing the status of the installation.

13. In the Oracle Net Configuration Assistant window, click Next.

14. Select No, I want to defer this configuration to another time and click 
Next.

15. From the Oracle Net Configuration Assistant, Naming Methods 
Configuration, Select Naming Methods dialog box, ensure that Local is 
the selected naming method and click Next.

16. Select Oracle8i or later database or service and click Next.

17. Enter the Service Name and click Next.

18. Choose TCP and click Next.

19. Enter the Host Name.

20. Select Use standard port number of 1521 and click Next.

21. Select Yes, perform a test and click Next.

.

22. Click Next.

23. Choose a name for this net service name and click Next.

24. Select No and click Next.

Note: Depending on the products you select, you may 
have more options within the wizard that are not related to 
the Migration Workbench. Follow the wizard options 
available for those products.

Note: If the Migration Workbench Repository database has a 
listener using a port number other than 1521, select Use another 
port number, enter the correct port number and click Next.

Note: If the destination Oracle database is not the same as the 
Migration Workbench Repository, you should click Yes and follow 
the instructions accordingly.
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25. Click Next.

26. Click Next.

27. Click Finish.

28. Click Exit.

29. Click Yes.

Issues Installing the Migration Workbench
In order to obtain a successful migration, consider the following, when 
Installing into an Oracle Home Directory.

Installing into an Oracle Home Directory
Since the Migration Workbench release 9.2.0 includes Oracle 9.2.0 
dependencies, it can only be installed into an Oracle 9.2.0 home directory or 
its own home directory. If there is a previous release of Oracle installed on 
the system, you must install the Migration Workbench into a separate 
Oracle home directory. 

You then need to switch the default Oracle home directory to point to the 
previous Oracle installation so that you do not pick up the new NT client 
dependencies for other applications you may use on the system. 

To switch the Oracle home directory:

1. Click Start -> Program Files -> Oracle Installation Products-> Home 
Selector.

2. Change the primary Oracle home by selecting the desired Oracle home 
from the Name drop-down list.

3. Click OK.

.

If you attempt to install into an Oracle home directory other than Oracle 
9.2.0 home directory, the Oracle Universal Installer displays the following 
error message: 

Migration Workbench can only be installed into a new %ORACLE_HOME% or 
an existing Oracle 9.2.0 %ORACLE_HOME%.

Note: The Home Selector is automatically installed when 
you install the Oracle Installation Products.
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Launching the Migration Workbench
After installing the core and at least one plug-in, you can launch the 
Migration Workbench. If you are running Microsoft Windows 98, restart the 
system before running the Migration Workbench. Rebooting the system 
resets the path for the JRE. 

To launch the Migration Workbench:

1. Choose Start -> Programs.

2. Navigate to the Oracle home directory.

3. Go to the Configuration and Migration Tools program group.

4. Select the Migration Workbench icon.

Problem Launching the Migration Workbench from Microsoft Windows 98 
While launching the Migration Workbench from Microsoft Windows 98, 
you may obtain the Finished - Shortcut To dialog box containing the 
following error message: 

Out of environment space
Out of environment space
Bad command or file name 

To launch the Migration Workbench after receiving these error messages: 

1. Right-click on the top bar of the DOS box, then choose Properties. 

2. Select the Memory tab. 

3. Change the Initial environment property from Auto to 1024. 

4. Click Apply. 

5. Click OK to accept the changes to the memory settings.

6. Click OK. 

7. Relaunch the Migration Workbench. 

Note: If you have problems launching the Migration 
Workbench, see the Problem Launching the Migration 
Workbench from Microsoft Windows 98 topic.
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Installation Structure
The Migration Workbench release 9.2.0 supports the migration of Microsoft 
SQL Server 6.5, Microsoft SQL Server 7.0, Microsoft SQL Server 2000, 
Sybase Adaptive Server 11, Sybase Adaptive Server 12, MySQL 3.22 and 
3.23, Microsoft Access 2.0, 95, 97, 2000, Informix Dynamic Server Version 
7.3, and IBM DB2/AS400 V4R5 to Oracle9i or Oracle8i. The Migration 
Workbench is located in the Oracle home directory, %ORACLE_
HOME%\Omwb. This directory contains all components of the Migration 
Workbench in several sub-directories as follows: 

■ Addins - Contains add-in programs used by the Migration Workbench 
to migrate the source database to Oracle.

■ Bin - Contains the batch file, omwb.bat, required to launch the 
Migration Workbench. It also contains the state.properties file that is 
created when the Migration Workbench is launched. This file is used to 
specify the default system Web browser that the Migration Workbench 
uses. For more information about using the default browser, see the 
Configuring the Migration Workbench to Use the Default Browser 
topic.

■ Docs - Contains the Oracle Migration Workbench Frequently Asked 
Questions, the Oracle Migration Workbench Release Notes, and the 
Oracle Migration Workbench Quick Tour.

■ Drivers - Contains the appropriate drivers required by the Migration 
Workbench.

■ Jlib - Contains the Java libraries, images, and online help files.

■ Log - Contains the SQL scripts, Created.sql and Drops.sql, that are 
generated when you run the Migration Wizard. It contains the 
Errors.sql file that saves all the errors generated by the Migration 
Workbench, and the reports files are also generated here. It also 
contains the reports generated by the Migration Workbench.

■ Migration_scripts - Contains the Create.sql and Drop.sql files 
generated when you choose the Action -> Generate Migration Scripts 
option within the Migration Workbench. You overwrite these files every 
time you generate the migration scripts.

■ Msaccess_exporter - Contains two omwb.mde files, omwb97.mde and 
omwb2000.mde, used to execute the Oracle Migration Workbench 
Exporter for Microsoft Access application. You use this application to 
export the schematic and table information from the Microsoft Access 
database to an XML file. You can then use the XML file that represents 
the Microsoft Access database to migrate to Oracle.
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■ Olite - Contains an Oracle Lite database with the default Migration 
Workbench repository. This allows the user to run the Migration 
Workbench without having to connect to a live Oracle database.

■ Plugins - Contains a .jar file for each supported database plug-in.

■ Sqlloader_scripts - Contains the files generated for off-line data 
loading. This occurs when you choose the Object -> Generate 
SQL*Loader Scripts option within the Migration Workbench.

Migration Workbench Repository
The Migration Workbench release 9.2.0 only works with a repository 
created by this release. You can create a Migration Workbench repository in 
an Oracle9i or Oracle8i database. To create a repository, you must create a 
user in the Oracle database where you want to store the Migration 
Workbench Repository. You must have already granted CONNECT and 
RESOURCE pre-defined roles to this user. The first time you log in to this 
user account you are asked if you would like to create the repository. The 
user name, password, and service that you enter in the Oracle Migration 
Workbench Repository Login dialog box define where you want to create 
the repository.

During the capture phase of the migration, the Migration Workbench takes 
a snapshot of the data dictionary of the database being migrated to Oracle. 
This information is stored in the repository and the amount of space 
required for it depends on the size of the database being migrated. It is 
recommended that you have at least 30MB of space available in the default 
tablespace of the repository owner to accommodate the snapshot and the 
meta data of the Migration Workbench.

Installation Configuration
In order to use the Migration Workbench to successfully migrate to an 
Oracle database, you need the following:

■ An Oracle9i or Oracle8i database where the Migration Workbench can 
create and store its repository, unless you are using the Oracle default 
repository.

■ For Microsoft SQL Server and Sybase Adaptive Server, a configured 
ODBC driver is required. 

■ For MySQL, you must have a JDBC driver installed and configured. 

■ For Informix Dynamic Server, you must have a JDBC driver installed 
and configured. 
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■ For Microsoft Access, a configured Microsoft Access ODBC driver is 
required. The Oracle ODBC driver must also be configured to point to 
the destination Oracle database.

■ For IBMDB2/AS400 V4R5, you must have a JDBC driver installed and 
configured.

■ A user with CONNECT and RESOURCE privileges to access the Migration 
Workbench Repository, unless you are using the default repository.

■ A user with DBA privileges to access the destination Oracle database. 

■ A destination Oracle9i or Oracle8i database where the Migration 
Workbench can create the schema objects and move the data from the 
source database to the destination Oracle database.

■ The Migration Workbench must also know the Net Service Names that 
point to the repository and to the destination Oracle database where 
you intend to migrate. If the database that contains the repository is not 
the destination Oracle database, you must create two Net9 Aliases. One 
Net9 Alias is for the repository and one is for the destination Oracle 
database.

Aliases are defined in the following file: 

%ORACLE_HOME%\network\admin\tnsnames.ora

To add or edit a Net Service Name, run the Oracle Net Configuration 
Assistant tool from the Configuration of Migration Tools program 
group in the Oracle home directory.

Configuring the Migration Workbench to Use the Default Browser
To view Migration Workbench HTML files, such as the Quick Tour, the 
release notes, or reference guide, the Migration Workbench attempts to 
activate the default browser on a Microsoft Windows 98/2000 or Microsoft 
Windows NT system. However, the Migration Workbench does not know 
the name or path of the default browser. It relies on the Microsoft Windows 
file associations to activate the browser, if one exists. 

To avoid any Web browser problems, the state.properties file is used to 
specify the exact path of the system browser. The state.properties file is 
automatically generated the first time you launch the Migration 
Workbench.
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If there is a problem executing the browser command on a Microsoft 
Windows system, you receive the following error message:

Problem executing Browser command <command executed>. Please 
specify the browser path in the 
<c:\Oracle\Ora9\Omwb\state.properties> initialization file for the 
BROWSER_PATH property, then restart the Migration Workbench. For 
more information please read the release notes.

To ensure the Migration Workbench launches the correct browser you must 
edit the state.properties file:

1. Close the Migration Workbench.

2. Navigate to the %ORACLE_HOME%\Omwb\bin directory.

3. Open the state.properties file.

4. In the BROWSER_PATH section enter the exact path of the browser 
the Migration Workbench should use. For example: 

c:\Program Files\Netscape\Communicator\Program\Netscape.exe

5. Choose File->Save and click Save.

6. Restart the Migration Workbench for the changes to take effect.

Online Support
The Migration Workbench Development Team provides support and 
solutions to the migration problems. Choose Help -> Online Support to 
launch a page that explains how to report a problem. It also provides a list 
of the supported platforms and additional documentation. For more 
information, see the Oracle Migration Workbench Help desk at:

http://otn.oracle.com/support/tech/migration/workbench/content.html

Note: In Netscape version 4.7 you can only open one 
Migration Workbench HTML file, such as the Quick Tour, 
at a time. For example, if the Quick Tour is open, you must 
close it before you can open the Oracle Migration 
Workbench Release Notes.
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Limitations and Bugs
In order to report a bug, refer to the Online Support page within the 
product. For more information about reporting bugs, see the Online 
Support topic. This section contains the following topics:

■ Microsoft Access Issues

■ Open Bugs

■ Fixed Bugs

Microsoft Access Issues
The following issues must be considered when using the Migration 
Workbench to migrate a Microsoft Access database to Oracle:

■ Secured Microsoft Access Databases

■ Replica Databases

■ Multi-level Linked Tables in Microsoft Access

■ Offline Scripted Data - BLOBs

■ Offline Scripted Data - CLOBs

Secured Microsoft Access Databases The Migration Workbench does not 
support the migration of Microsoft Access security settings, such as the user 
name and password. In order to migrate a secured database, you must first 
make a copy of it. This duplicates the contents of the Microsoft Access 
database without the security. You can than take the new Microsoft Access 
database and migrate it to Oracle using the Migration Workbench.

To copy the contents of the Microsoft Access database:

7. Create a new empty Microsoft Access database by choosing File -> 
New Database.

8. Select Blank Database and click OK.

9. From the File New Database dialog box, type a name for the 
database and click Create.

10. From within the new database, choose File -> Get External Data -> 
Import.

11. Select the secured Microsoft Access database you want to import.

12. From the Import Objects dialog, click Options. Ensure that the 
Relationships and Data and Definitions options are selected.

13. From the Tables tab, choose Select All. 

14. Click OK.
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Replica Databases The Migration Workbench does not support the 
migration of a replica Microsoft Access database. Select the master database 
to migrate to Oracle.

Multi-level Linked Tables in Microsoft Access The Migration Workbench only 
supports one level of linked tables. If you have a table with links to a 
second table, these links are preserved. However, links in the second table 
are not migrated to Oracle.

Offline Scripted Data - BLOBs The Migration Workbench is unable to load 
BLOBs when you choose Object -> Generate SQL*Loader Scripts to 
generate off-line data loading.

Offline Scripted Data - CLOBs The Migration Workbench is unable to load 
CLOBs that contain line breaks when you choose Object -> Generate 
SQL*Loader Scripts to generate off-line data loading.

Open Bugs
Bug 1509958

Description: Timestamp columns do not load with SQL*Loader direct path 
load. When a timestamp column is migrated to Oracle the Migration 
Workbench generates a sequence and a trigger to mimic the behavior of the 
timestamp column. However, when you migrate the data in Migration 
Workbench release 1.3.0 or migration Workbench release 1.3.1 using 
SQL*Loader, the Migration Workbench uses the direct=true syntax in 
the sql_load_script.bat file. This means that the sequence and trigger are 
bypassed and the original timestamp entry is inserted into the column with 
an error.

Workaround: In order to load timestamp columns correctly, you must 
manually edit the sql_load_script.bat file and remove the direct=true 
syntax for the table that contains the timestamp column. The sql_load_
script.bat file is located in the %ORACLE_HOME%/Omwb/sqlloader_
scripts/<plug-in name>/<timestamp>/oracle directory. 

Bug 1333552

Description: The Microsoft Access plug-in does not support databases 
(MDB files) with spaces in their name. 

Workaround: Rename the MDB file so that it does not contain a space. The 
migration should then function correctly.
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Fixed Bugs

Bug No Plug-in Description

2255531 INFORMIX73 RENAME USER IN ORACLE MODEL DOES NOT 
MAP INFORMIX SYSTEM PRIVS

2255518 INFORMIX73 GENERATE MIGRATION SCRIPT DOES NOT 
SHOW SYSTEM PRIVS GRANTED

2253447 COMMON GENERATE REPORTS IN ACCESS CAUSES A 
STACK TRACE

2253319 DB2-400 ERRORS AND WARNINGS DIALOG NOT 
ACCURATE AFTER CAPTURE

2251682 DB2-400 SOME FOREIGN KEYS DO NOT SEEM TO MAP TO 
ORACLE MODEL

2251670 COMMON DELETE ALL FOREIGN KEYS FROM ORACLE 
MODEL - TEXT NOT CORRECT

2251333 DB2-400 POPUP MENU NOT AVAILABLE FOR USERS 
FOLDER IN SOURCE MODEL

2247460 DB2-400 SOURCE MODEL TABLE DB2400V4R5 - TABLE 
TREE ITEMS VERY SLOW TO DISPLAY

2247339 COMMON WORKBENCH HANGS WHEN STOPING THE 
MIGRATION WHEN A PK IS NOT CREATED

2247259 TSQLPARSE INSERT INTO TABLENAME (COLUMNNAME) 
INCORRECTLY GENERATED

2245263 LITE-REPOS OMWB.ODB DOES NOT CONTAIN MOST 
UP-TO-DATE SCHEMA FOR DB2\400 V4R5

2243311 LITE-REPOS ALTERING PCTFREE ON A TABLE AND 
REFRESHING CAUSES A STACK TRACE ON OLITE

2235304 INFORMIX73 LOG WINDOW SUMMARY MISSES ERROR 
CREATING DEFAULT

2233884 INFORMIX73 ORACLE MODEL NOT TRUNCATED ON 
RE-CAPTURE WHEN ESQL/C 
CAPTURE\CONVERT PERFORMED

2233752 INFORMIX73 OMWB HANGS WHEN ESQL\C TO PRO*C 
CONVERT IS ATTEMPTED

2233674 INFORMIX73 "PRO*C SOURCES" FOLDER NOT CLEARED ON 
SUBSEQUENT ESQL\C CAPTURE

2233607 DOC MYSQL REFERNCE GUILDE - BROKEN LINK 
A.HTM

2233601 DOC MYSQL REFERENCE GUIDE - BROKEN LINK 
RCF.HTM 
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2233585 DOC CAPTURE WIZARD DISCONNECTED LOAD HELP 
DOES NOT WORK, ON SQLSERVER6.5

2233553 DOC MYSQL REFERENCE GUIDE - INDEX LINK 
WRONG

2233505 SYBASE NO HELP FOR FOREIGN KEYS FOLDER IN 
SOURCE MODEL OF SYBASE11

2231978 SQLSERVER DISCONNECTED SOURCE MODEL LOAD HAS 
DATE PROBLEMS

2231820 DOC ESQL/C CAPTURE WIZARD/CONVERT 
WIZARD/GENERATE WIZARD HELP NOT 
WORKING...

2231581 COMMON OMWB HANGS AFTER ATTEMPT TO CREATE A 
NEW TABLESPACE

2231550 DOC DB2/400 V4R5 DOC BUG LIST 

2230197 DB2-400 TEXT IN STEP 1 OF DB2 V4R5 CAPTURE WIZARD 
IS SLIGHTLY INCORRECT

2230190 DB2-400 ADA COMPLIANCE "&" HAS NO MNEMONIC FOR 
TABLE PRIMARY KEY

2230166 COMMON WORKBENCH HANGS WHEN ORACLE MODEL 
TAB IS SELECTED

2230058 ACCESS ACCESS PLUG-IN CANNOT LOAD SOURCE 
MODEL

2228330 DB2-400 TIMESTAMP AND TIMESTMP IN DB2 SHOULD 
NOT BE MAPPED TO TIMESTAMP BY DEFAULT

2228062 MYSQL PK NOT REMOVED WHEN ASSOCIATED TABLE 
REMOVED IN SOURCE MODEL

2228056 SQLSRV2000 TRIGGERS AND VIEWS FAIL TO PARSE 
INDIVIDUALLY

2228044 SQLSRV2000 SQL EXCEPTION ORA-01418 OCCURS DURING 
SOURCE MODEL TRUNCATION

2226115 INFORMIX73 ’&OWNER’ APMERSAND APPEARS IN TEXTBOX 
LABELS

2226064 COMMON ORACLE MODEL TREE REFRESH ISSUE WHEN I 
DELETE A TABLE OBJECT...

2219170 SQLSRV2000 STATISTICS STORED IN THE SYSINDEXES TABLE 
BEING TREATED AS REAL INDEXES IN DDL

2219078 SQLSERVER7 DEFAULT DATETIME LITERALS NEED TO 
MAPPED TO TO_DATE(’DATE’,’MASK’)

2217628 COMMON OWNER OF OBJECTS NOT CORRECT IN REPORTS

Bug No Plug-in Description
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2217485 COMMON WORKBENCH HANGS WHEN I TRY TO APPLY 
CHANGES TO COLUMN DATATYPES IN O.M. 
TABLE

2217042 COMMON INFORMATION MISSING FROM ORACLE MODEL 
INDEX PROPERTY PAGE

2215353 SQLSERVER7 DEFAULTS FOR USER, CURRENT_USER, SESSION_
USER, SYSTEM_USER NOT MIGRATED

2215298 COMMON ERRORS RECORDED DURING DATAMOVE NOT 
TAGGED AS ERRORS IN THE DETAILED REPORT

2209687 COMMON ALTERATION OF STORAGE OPTIONS ON 
INDEXES GROUP CAUSES ERRORS IN 
MIGRATION

2208040 COMMON TIME() FUNCTION PARSED INCORRECTLY BY 
EXPORTER

2206038 COMMON CORE: _UPGRADEPLUGINTABLEENTRIES 
MISSING COMMA IN SQL, UPDATE FAILS 

2204215 SYBASE SYBASE 11.5.1 DATABASES CANNOT BE 
CAPTURED WITH SYBASE 11.9.2 PLUG-IN

2200029 COMMON SUMMARY REPORT TABLE DISPLAYS MULTIPLE 
ENTRIES FOR STORED PROCEDURES & 
PACKAGES

2198362 TSQLPARSE FUNCTION CALLS GENERATED INCORRECTLY

2198183 WSDK THE TEMPDB DATABASE IS NOT LISTED IN THE 
CAPTURE WIZARD AS A DATABASE TO CAPTURE

2198171 TSQLPARSE GENERATION OF SUB SELECTS IN A SELECT 
STATEMENT IS INCORRECT.

2198161 TSQLPARSE "EXEC SERVERNAME...PROCNAME" SYNTAX NOT 
ACCEPTED

2198159 TSQLPARSE IDENTITY SYNTAX NOT HANDLED BY THE 
PARSER.

2198155 TSQLPARSE "AT ISOLATION" SYNTAX NOT ACCEPTED BY THE 
PARSER

2198145 TSQLPARSE THE SYNTAX SET ENVIRONMENT VARIABLES IS 
NOT YET HANDLED BY THE PARSER 

2198139 TSQLPARSE INDEX HINT SYNTAX IS NOT ACCEPTED BY THE 
PARSER

2198131 TSQLPARSE IF NULL GETS SENT TO THE PARSER. THE ERROR 
MESSAGE IS NOT VERY HELPFUL.

Bug No Plug-in Description
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2198130 WSDK OMWB RUNS OUT OF CONNECTIONS WHILE 
MAPPING THE CHECK CONSTRAINTS.

2198107 WSDK MULTIPLE CONSTRAINTS SHOWN IN THE 
SOURCE TREE INCORRECTLY.

2198093 TSQLPARSE COMMENT(S) BETWEEN "CREATE" AND "VIEW" 
CAUSES THE PARSER TO FAIL

2198088 TSQLPARSE PROCEDURES FAILS TO PARSE WHEN A SINGLE 
LINE COMMENT IS THE LAST LINE IN THE SQL

2198081 TSQLPARSE PROCEDURE,VIEW & TRIGGER NAMES NOT 
COLLISION MANAGED IN THE SQL TEXT

2198069 TSQLPARSE TEMP TABLES NOT RESOLVED IN DDL 
STATEMENTS

2180192 SQLSERVER7 SQL SERVER 7.0 NOT UPDATED TO ALLOW BIT 
DATA TO BE A NULL.

2146842 INFORPARSE PASRSER HAS PROBLEM PARSING VARIABLE 
NAME "END" WHICH IS A KEYWORD

2135091 ACCESS POST MIGRATION: ODBC CONNECTION FAILS 
WHEN USING DAO 3.6 WITH ACCESS 97

2121343 INFORPARSE LIKE COLUMN || "%" NOT PARSED

2121342 INFORPARSE ORDER BY CLAUSE NOT PARSED CORRECTLY

2115588 WSDK WORKBENCH SHUTS DOWN PREMATURELY

2112052 INFORPARSE LENGTH(A.B) CAUSES A PARSE ERROR

2108394 TSQLPARSE FUNCTION NOT BEING PARSED DURING 
CREATION OF ORACLE MODEL

2103935 INFORMIX73 SUMMARY REPORT IS MIXING UP PRIVILEGS 
AND STRORED PROCEDURES DATA

2102173 SQLSERVER7 SQL SERVER MINIMUM FLOAT VALUE IS NOT 
MIGRATED 

2099619 INFORMIX73 FAILED TRIGGER MESSAGE DURING DB 
CAPTURE NOT BEING PICKED UP BY DATABASE 
REPORTS

2097946 MYSQL LACK OF INFO LOGS IN PROGRESS WINDOW 
DURING CAPTURE PHASE

2079324 TSQLPARSE CREATE INDEX MYINDEX ON 
TABLENAME(COLUMNAME ASC) CAUSE A 
PARSE ERROR

2033921 INFORMIX73 ISSUE#24 (POL) STRANGE UI HANG WHEN 
SELECTING USERS TO GENERATE SCRIPTS

Bug No Plug-in Description
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2031248 TSQLPARSE THE CONVERT FUNCTION WITH "REAL" FAILS 
WHEN IN SOME CIRCUMSTANCES

2026189 INFORPARSE A PROBLEM WITH PROCESSING THE 
YEAR/SECOND UNIT EXPRESSIONS IN STORED 
PROCEED

2019335 SQLSERVER7 WHEN USING THE OLITE REPOSITORY A 
SUCCESSFUL CAPTURE CANNOT BE CARRIED 
OUT

2014234 ACCESS RENAMED TABLESPACE IN ORACLE MODEL IS 
NOT BEING REFLECTED DURING MIGRATION

1943413 MYSQL AUTO-INCREMENT TRIGGER TRUNCATION

1891549 ACCESS CREATION OF ORACLE MODEL HANGS ON 
MAPPING TABLES.

1877386 LITE-REPOS ERRORS IN MIGRATION WHEN THE FIRST 
CHARACTER IN DATABASE NAME IS A NUMBER

1875316 LITE-REPOS OLITE: ERRORS IN CAPTURE PHASE NOT 
APPEARING IN ERROR REPORT

1854042 ACCESS ORACLE DBA RIGHT IS NEEDED WHEN 
MODIFYÍNG THE MDB

1807122 WSDK PROBLEMS WITH ERROR REPORT IF THE ODBC 
DRIVER IS THE SAME NAME AS THE DATABASE

1802464 TSQLPARSE CAST OPERATOR (SIMILAR TO CONVERT) NOT 
SUPPORTED

1785699 INFORPARSE CALLS TO OTHER STORED PROCEDURES 
WITHOUT ARGUMENTS CAUSE ERRORS.

1785605 COMMON HANDLING OF ERROR MESSAGE DURING 
MIGRATION

1771449 COMMON 'RENAME' THEN 'DELETE' OF OBJECT FROM 
ORACLE MODEL CAUSES WORKBENCH TO 
HANG

1759178 COMMON CHANGING PARSE OPTIONS NOT APPLYING 
UNLESS APPLY CLICKED OR OTHER PROC 
SELECTED

1456246 WSDK THE "DO YOU WISH TO SAVE CHANGES" 
WINDOW IS NOT EFFECTIVE

1424599 WSDK CAPTURE WIZARD - PAGE 1 OF 4 - SOURCE 
DATABASE DETAILS
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